temperature jumps around with 612 PID

urielmaimon
Posts: 5
Joined: Sun Jul 21, 2013 3:08 pm

temperature jumps around with 612 PID

Postby urielmaimon » Sun Jul 21, 2013 3:16 pm

Hi

I built a sous vide setup with the same components everyone else seem to use (PT100 thermocoupler, 612 PID, 25A SSR). Everything seems to work ok, except the temperature on the PID keeps jumping up and down (5 degrees at a time!). I did attach the red connector of the thermocoupler to Terminal 8,etc. Is this a problem with the thermocoupler? with the PID? with configuration? with my karma?

Thanks in advance,

Uriel

Tech_Marco
Posts: 4347
Joined: Mon Jun 15, 2009 3:00 pm

Re: temperature jumps around with 612 PID

Postby Tech_Marco » Wed Jul 24, 2013 11:20 am

It could be the probe issue. Also, where did you install the controller? Make sure it is not next to the heating element as temperature will affect the controller a lot. There is a 'diode' on pin#11 and it is a temperature sensor for compensation. By the way, do not make the pt100 wet inside. Only tip is ok to touch water or it will cause the problem. If so, dry it up and it should work fine


Marco

urielmaimon
Posts: 5
Joined: Sun Jul 21, 2013 3:08 pm

Re: temperature jumps around with 612 PID

Postby urielmaimon » Wed Jul 24, 2013 11:27 am

The controller is about a meter away, so that's probably not it. Could be the water thing... I ordered (from light object through amazon) the waterproof pt100. I'll put that in instead and update.

Thanks for the response!


Tech_Marco wrote:It could be the probe issue. Also, where did you install the controller? Make sure it is not next to the heating element as temperature will affect the controller a lot. There is a 'diode' on pin#11 and it is a temperature sensor for compensation. By the way, do not make the pt100 wet inside. Only tip is ok to touch water or it will cause the problem. If so, dry it up and it should work fine


Marco

Tech_Marco
Posts: 4347
Joined: Mon Jun 15, 2009 3:00 pm

Re: temperature jumps around with 612 PID

Postby Tech_Marco » Wed Jul 24, 2013 11:36 am

If the probe you purchased from us is defective, you can send it back for either refund or exchange

Marco

urielmaimon
Posts: 5
Joined: Sun Jul 21, 2013 3:08 pm

Re: temperature jumps around with 612 PID

Postby urielmaimon » Wed Jul 24, 2013 1:24 pm

It was the water! the stainless still pt00 didn't jump around when in dry air, or if I just submerged it in a glass of water. I put in the waterproof one and everything is dandy. Autotuning as we speak. I do have a problem with the water pumps, but I'll post about that in electronics.

Tech_Marco wrote:If the probe you purchased from us is defective, you can send it back for either refund or exchange

Marco


Return to “Temperature Controller”

Who is online

Users browsing this forum: No registered users and 3 guests