Lightobject 600W Mini Water Chiller wont CHILL

litterbox99
Posts: 41
Joined: Mon Oct 19, 2015 4:54 pm

Lightobject 600W Mini Water Chiller wont CHILL

Postby litterbox99 » Sat Oct 08, 2016 4:17 pm

I was getting ready to fire up the laser this weekend and the chiller
wont chill. If anything, the temperature just climbs.

I have done a reset to factory parameters by holding up/down arrow
for a few seconds until the display shows rE.

When I power it up D1 is lit and D2 flashes for about 30 seconds.
After that, it sounds like the fan/compressor starts to run. D1 & D2
are solid and the display shows 24.XX C The temp climbs with run time
and doesn't drop, it should be cooling. I have confirmed the default
F0 - F9 parameters per the manual. I'm guessing the refrigeration
unit isn't working :-(

Is this a setting issue ? or a Warranty issue ?

Techgraphix
Posts: 434
Joined: Fri Jan 20, 2012 1:39 pm
Location: Appelscha, the Netherlands
Contact:

Re: Lightobject 600W Mini Water Chiller wont CHILL

Postby Techgraphix » Sun Oct 09, 2016 2:20 am

Just a few stupid questions: is the waterflow OK? Can there be a big airbubble trapped in the chiller? Does the chiller generate some heat (which should mean that i does cool something)? Is it easy to open (without loosing warranty, ofcourse), so you can check the temperatures in the piping?
Kees

litterbox99
Posts: 41
Joined: Mon Oct 19, 2015 4:54 pm

Re: Lightobject 600W Mini Water Chiller wont CHILL

Postby litterbox99 » Sun Oct 09, 2016 8:49 am

Got up this morning to give it another try...

Checked default parameters, F0 = 25c & F3 was intelligent mode.
I did another factory rest, F0=20c and in refrigeration mode.
Turned unit on, D2 flashes for about 30 seconds and the the
fan turns on. Temp display indicates 22.5c. At this point I
would imagine it should be chilling the water until it reaches
20c but the temp doesn't drop. The unit ran for 30 minutes
(this time) with no drop in temp.

Yes, it has water and is pumping/circulating, no air bubbles.

I'll take the case off and see if the refrigerant lines get cold
or have a look with my FLIR camera...

Last two days of my vacation and I just wanted to test fire
the laser before I install my optics :-(

litterbox99
Posts: 41
Joined: Mon Oct 19, 2015 4:54 pm

Re: Lightobject 600W Mini Water Chiller wont CHILL

Postby litterbox99 » Sun Oct 09, 2016 10:47 am

Took cover off, refrigerant lines do not get cold.
There is a light mist of oil on copper lines, must
be where the leak is. Talked to an AC guy to see
if it could be recharged (yes) but if the compressor
ran for a while without freon, it's also bad.

Tech_Marco
Posts: 4165
Joined: Mon Jun 15, 2009 2:00 pm

Re: Lightobject 600W Mini Water Chiller wont CHILL

Postby Tech_Marco » Sun Oct 09, 2016 12:42 pm

It could be leaking. One of connection bond between the stainless coil and the copper tube didn't bond well. So, new welding may be required.

If there is too much trouble, you may want to ship it back to us for diagnostic and refill if leaking


Marco

litterbox99
Posts: 41
Joined: Mon Oct 19, 2015 4:54 pm

Re: Lightobject 600W Mini Water Chiller wont CHILL

Postby litterbox99 » Sun Oct 09, 2016 1:17 pm

Marco,

That's a nice offer, but I ran it for a few hours, just concerned
about the compressor may be bad now (ran low on oil) it was hot !

It'll will cost me $95 to ship it back, I'd rather exchange it for a
new one if I have to pay.

I'm sure we can work it out.

Tech_Marco
Posts: 4165
Joined: Mon Jun 15, 2009 2:00 pm

Re: Lightobject 600W Mini Water Chiller wont CHILL

Postby Tech_Marco » Mon Oct 10, 2016 11:13 am

We're sorry you're still having issues with the chiller. I'll contact you right away so that we can get this straightened out for you ASAP!

Thank you!

Tech Marco


Return to “Temperature Controller”

Who is online

Users browsing this forum: No registered users and 6 guests