New to the board with spt 850mm co2 sealed laser tube (40w)

FILO
Posts: 1
Joined: Fri Mar 24, 2017 5:42 pm

New to the board with spt 850mm co2 sealed laser tube (40w)

Postby FILO » Sun Mar 26, 2017 9:02 am

I have a FSLaser Series 20x12 5th Gen https://www.fslaser.com/Product/Hobby. I have had nothing but trouble with tubes from FSLaser. The LO spt 850mm co2 sealed laser tube (40w) was suggested to me. I ordered the tube and it arrived promptly and packaged very well. On inspection I could not find any problems. Until I installed it. I installed it the way I have always done (cathode and anode facing up). I ran some test pulses to check alignment and started a small raster job. At each end of the raster I hear a faint "pop" sound coming from the back end of the tube. I immediately stopped the machine. Water is flowing. I rechecked the cathode and anode connections. The beam looks good while firing.

The laser was running normally with the old tube and nothing was changed but the tube.

Anyone have any ideas?

Tech_Marco
Posts: 4371
Joined: Mon Jun 15, 2009 3:00 pm

Re: New to the board with spt 850mm co2 sealed laser tube (40w)

Postby Tech_Marco » Thu Mar 30, 2017 10:51 pm

Just fire up the laser without gantry movement see if you hear anything. Then do one straight line testing. After that, do a circle cutting. Compare all these tests and post the results here. That may give us some thought here. Thx

Marco


Return to “CO2 Laser Discussion”

Who is online

Users browsing this forum: No registered users and 11 guests