LO X7 or power supply issue , Help Please - SOLVED

ei9gwb
Posts: 6
Joined: Thu Jun 18, 2015 2:26 am

LO X7 or power supply issue , Help Please - SOLVED

Postby ei9gwb » Sun Aug 20, 2017 1:10 pm

Hi ,
today got issue with my laser , firstly when cutting laser was loosing power ( it was looks like) , after that there was a problem with upload file to LOx7 ,
then when try engrave picture was intermittent like. then I try to cut a square and effect you can see on video
https://youtu.be/Q14SaBh1FFI
when press laser button on LOX7 laser don't fire up , when reset LOX7 and press laser button is fire up but visibly loosing power.
like for me looks like power supply issue but im not sure , any advise welcome

Regards
Arek
Last edited by ei9gwb on Sun Aug 20, 2017 4:07 pm, edited 1 time in total.

anable
Posts: 2
Joined: Fri Aug 11, 2017 12:10 pm

Re: LO X7 or power supply issue , Help Please

Postby anable » Sun Aug 20, 2017 3:09 pm

You can use a multimeter on the cathode (negative) line running between your laser and power supply. Should tell you if the supply is putting out steady power or not. Please be careful and don't touch the red/positive/anode line. It carries enough electricity to seriously hurt you.

ei9gwb
Posts: 6
Joined: Thu Jun 18, 2015 2:26 am

Re: LO X7 or power supply issue , Help Please

Postby ei9gwb » Sun Aug 20, 2017 4:07 pm

After all Sunday spent under machine cover finally solved problem,
anyway reason was IDIOTIC :eek: ,
it was Short Cirquit on pointer diode,

Problem Solved 1 Experience point gained.

Regards

JB68
Posts: 1
Joined: Fri Sep 23, 2016 10:28 am

Re: LO X7 or power supply issue , Help Please - SOLVED

Postby JB68 » Sat Jan 27, 2018 5:42 pm

I have just wired in my new power supply. When I press the laser button on my X7 it reboots. Also when I press the test button on the power supply the laser won't fire. If I remove the connector on the power supply from the controller and test fire the power supply the laser works. My power supply is brand new but I am also concerned they may be an issue with my X7. Any ideas how to diagnose or where to start.

Tech_Marco
Posts: 4401
Joined: Mon Jun 15, 2009 3:00 pm

Re: LO X7 or power supply issue , Help Please - SOLVED

Postby Tech_Marco » Sat Jan 27, 2018 10:55 pm

Check the grounding of your laser machine. Make sure that the ac outlet got good grounding I mean a real ground. Also, make sure laser tube connections are properly connected and firmed. It is very easy to have bad or loosen ground wire on the negative terminal from the tube. The casing of the laser power supply must be well grounded or interference mayy occurred and causing controller board reset itself. Worst case, the feedback could damage electronic parts in your machine like the DSP controller


Marco

SWMS
Posts: 158
Joined: Mon Jan 06, 2014 4:28 am

Re: LO X7 or power supply issue , Help Please - SOLVED

Postby SWMS » Thu Mar 22, 2018 11:52 pm

I now use IP68 17 amp at 400v in-line connectors for my positive and negative connections. Dirt cheap and very safe!


Return to “Electronics”

Who is online

Users browsing this forum: No registered users and 5 guests